summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2019-01-27 15:01:40 +0000
committerWorMzy Tykashi2019-01-27 15:01:40 +0000
commit293b5ea9353ad5467aad7ef80987947aeb136305 (patch)
tree56238354e19b4aab796f17a030049bdd6c03caaa /PKGBUILD
parent8e067b0ed58a81290b81cc0c5204ce72c2749cf4 (diff)
downloadaur-293b5ea9353ad5467aad7ef80987947aeb136305.tar.gz
Fix cmake build, pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5671d655c076..c54371ffbe96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=openxcom-git
pkgname=('openxcom-git' 'openxcom-docs-git')
_gitname=OpenXcom
-pkgver=1.0_2491_gc7204b174
+pkgver=1.0_r2757_g4251ab7c8
pkgrel=1
pkgdesc="An open-source reimplementation of the famous X-COM game (git-version)"
arch=('i686' 'x86_64')
@@ -19,12 +19,15 @@ sha256sums=('SKIP')
pkgver() {
cd ${_gitname}
- git describe --tags | sed -e 's:v::' -e 's:-:_:g'
+ git describe --long --tags | sed -e 's:^v::;s:\([^-]*-g\):r\1:;s:-:_:g'
+}
+prepare() {
+ mkdir -p ${_gitname}/build
}
build() {
- cd ${_gitname}
- cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE="Release" -DDEV_BUILD="Off"
+ cd ${_gitname}/build
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE="Release" -DDEV_BUILD="Off" ..
make
# Make documentation
@@ -41,7 +44,7 @@ package_openxcom-git() {
conflicts=('openxcom')
install="${pkgname}.install"
- cd ${_gitname}
+ cd ${_gitname}/build
make DESTDIR="${pkgdir}" install
}
@@ -49,7 +52,7 @@ package_openxcom-git() {
package_openxcom-docs-git() {
pkgdesc="Documentation for the open-source reimplementation of the famous X-COM game (git-version)"
arch=('any')
- cd ${_gitname}/docs
+ cd ${_gitname}/build/docs
install -dm755 "${pkgdir}/usr/share/doc/openxcom/"
cp -a html "${pkgdir}/usr/share/doc/openxcom/"
}