summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2017-12-30 18:04:07 +0000
committerWorMzy Tykashi2017-12-30 18:04:07 +0000
commit8e067b0ed58a81290b81cc0c5204ce72c2749cf4 (patch)
tree0bfafd6a86f8db23ac943e7bc7354bb0e08b2860 /PKGBUILD
parente371fbba72d9e163ed474c77b1b84d41388d4707 (diff)
downloadaur-8e067b0ed58a81290b81cc0c5204ce72c2749cf4.tar.gz
Updated url to use https, style changes, pkgver bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e82a88e4654c..5671d655c076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
pkgbase=openxcom-git
pkgname=('openxcom-git' 'openxcom-docs-git')
_gitname=OpenXcom
-pkgver=1.0_2177_gacd4eb3
+pkgver=1.0_2491_gc7204b174
pkgrel=1
pkgdesc="An open-source reimplementation of the famous X-COM game (git-version)"
arch=('i686' 'x86_64')
-url="http://openxcom.org/"
+url="https://openxcom.org/"
license=('GPL3')
makedepends=('git' 'xmlto' 'docbook-xml' 'docbook-xsl' 'doxygen' 'sdl_mixer'
'sdl_gfx' 'sdl_image' 'sdl' 'yaml-cpp' 'libgl' 'gcc-libs' 'glibc'
@@ -18,12 +18,12 @@ source=(git+"https://github.com/SupSuper/${_gitname}.git")
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd ${_gitname}
git describe --tags | sed -e 's:v::' -e 's:-:_:g'
}
build() {
- cd $_gitname
+ cd ${_gitname}
cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE="Release" -DDEV_BUILD="Off"
make
@@ -41,15 +41,15 @@ package_openxcom-git() {
conflicts=('openxcom')
install="${pkgname}.install"
- cd $_gitname
+ cd ${_gitname}
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" install
}
package_openxcom-docs-git() {
pkgdesc="Documentation for the open-source reimplementation of the famous X-COM game (git-version)"
arch=('any')
- cd $_gitname/docs
- install -dm755 "$pkgdir/usr/share/doc/openxcom/"
- cp -a html "$pkgdir/usr/share/doc/openxcom/"
+ cd ${_gitname}/docs
+ install -dm755 "${pkgdir}/usr/share/doc/openxcom/"
+ cp -a html "${pkgdir}/usr/share/doc/openxcom/"
}