summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author007exe2021-04-07 19:44:51 +0300
committer007exe2021-04-07 19:44:51 +0300
commit413450b2858b7a7b6c315fb43039fe6257125166 (patch)
treeb9f73c6c1ce4bc7aaf1388d58e9807339a8a7bfe /PKGBUILD
parente3c2585f914a2ea414273ed77996223569f310ea (diff)
downloadaur-413450b2858b7a7b6c315fb43039fe6257125166.tar.gz
removed intel-tbb dependency, removed mimalloc binaries from package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e57fcef7633..667f018bf1b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# https://aur.archlinux.org/packages/openxray-git/
# <openxray@yahoo.com>
pkgname=openxray-git
-pkgver=1.6.02
+pkgver=1.6.02_822
pkgrel=1
-pkgdesc="Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)"
+pkgdesc="Unofficial X-Ray Engine port for Linux from the OpenXRay team (originally developed by GSC Game World)"
arch=('x86_64')
url="https://github.com/OpenXRay/xray-16"
license=('custom:Custom 3-сlause BSD')
install="info.install"
makedepends=(gcc git cmake libglvnd libjpeg6-turbo ncurses pcre2 pcre)
-depends=(glew sdl2 openal intel-tbb crypto++ liblockfile freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo)
+depends=(glew sdl2 openal crypto++ liblockfile freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo)
conflicts=(openxray openxray-dev)
source=(xray-16::git+https://github.com/OpenXRay/xray-16.git#branch=dev)
md5sums=('SKIP')
pkgver() {
cd "$srcdir/xray-16"
- printf 1.6.02_"$(git rev-parse --short HEAD)"
+ printf 1.6.02_822_"$(git rev-parse --short HEAD)"
}
prepare(){
@@ -42,6 +42,7 @@ build() {
package() {
cd "$srcdir/xray-16/bin"
make DESTDIR="${pkgdir}/" install
+ rm -rf "${pkgdir}/usr/lib/mimalloc-1.6"
mkdir -p "${pkgdir}/usr/share/licenses/$pkgname/"
cp "$srcdir/xray-16/License.txt" "${pkgdir}/usr/share/licenses/$pkgname/"
}