summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortarberd2018-01-17 17:58:31 -0200
committertarberd2018-01-17 17:58:31 -0200
commit5dfc4d11b41ffe0f0641c47802c1da7aff1ce7fc (patch)
tree3796eb3f9e3f589a28d9ebf33596e8437ee9c6f7 /PKGBUILD
downloadaur-5dfc4d11b41ffe0f0641c47802c1da7aff1ce7fc.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf614933b32b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Bernardo Ferrari Mendonca <bernardo.mferrari@gmail.com>
+pkgname=ophidian-flute-git
+pkgver=1.0
+pkgrel=1
+groups=('ophidian')
+pkgdesc="A rectilinear Steiner minimal tree and wirelength algorithm described in the ICCAD 04 and ISPD 05 papers."
+arch=('x86_64')
+url="https://gitlab.com/eclufsc/Flute"
+license=('custom')
+makedepends=('make' 'bison' 'flex')
+source=('git+https://gitlab.com/eclufsc/Flute.git#branch=master')
+md5sums=('SKIP')
+
+
+build() {
+ cd $srcdir/Flute
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ install -d $pkgdir/usr/share/Flute
+ install -D -m 644 $srcdir/Flute/license.txt $pkgdir/usr/share/Flute/copyright
+
+ cd $srcdir/Flute/build
+ make DESTDIR="$pkgdir/" install
+}