summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIlya Lipnitskiy2015-11-17 14:23:40 -0800
committerIlya Lipnitskiy2015-11-17 14:29:19 -0800
commitd3bc33a168b7e275bc9f2e113b1220f677d08a99 (patch)
tree773571c76b678c0978b79a143ee8fb1e3f51c484 /PKGBUILD
downloadaur-d3bc33a168b7e275bc9f2e113b1220f677d08a99.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff72fd49413b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
+
+pkgname=opkg-git
+pkgver=v0.3.0.r35.f48bbea
+pkgrel=1
+pkgdesc="Opkg is a lightweight package management system based upon ipkg"
+arch=(x86_64)
+url="https://git.yoctoproject.org/cgit/cgit.cgi/opkg"
+license=('GPL')
+depends=('curl' 'libarchive' 'gpgme')
+makedepends=('git' 'automake' 'autoconf')
+conflicts=(opkg)
+source=("git+http://git.yoctoproject.org/git/opkg#branch=opkg-0.3.x")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd opkg
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd opkg
+ ./autogen.sh
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd opkg
+ make
+}
+
+package() {
+ cd opkg
+ make DESTDIR="$pkgdir/" install
+}