summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP Cimalando2018-05-05 00:23:16 +0200
committerJP Cimalando2018-05-05 00:23:16 +0200
commit56dd54a6e51b0e693b67b1d503100fb6223823ad (patch)
tree623cccce709195383a120623ac0446656a1197c4 /PKGBUILD
parent69649329eed6e6e11589877fd8c3d44c80b2a4ca (diff)
downloadaur-56dd54a6e51b0e693b67b1d503100fb6223823ad.tar.gz
bump version and checkout git submodules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac426cb5874b..d9cca328cc11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP Cimalando <jp-dev inbox.ru>
pkgname=opl3bankeditor-git
_pkgname=OPL3BankEditor
-pkgver=1.3.beta.r148.gcbca839
+pkgver=1.3.beta.r176.g8b5b03f
pkgrel=1
epoch=
pkgdesc="A small cross-platform editor of the OPL3 FM banks of different formats"
@@ -32,6 +32,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git submodule update
+}
+
build() {
cd "$_pkgname"
qmake