summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucki2018-09-21 00:42:15 +0200
committerLucki2018-09-21 00:42:15 +0200
commit62154e14b6c4f9738bd9cdcf0fc98399fdd3234a (patch)
tree4c4aa0700f35941efbd25d84a22190ca78488ea6 /PKGBUILD
parentc19cf005505136d484b532a6bde91db04d2a090b (diff)
downloadaur-62154e14b6c4f9738bd9cdcf0fc98399fdd3234a.tar.gz
SHorter lines and be more safe
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25303efc57ed..421e4df5e3b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor in email: tpenguinltg <https://aur.archlinux.org/account/tpenguinltg/>
pkgname=opsu-git
-pkgver=0.16.0.r0.gcf52c2f
-pkgrel=2
+pkgver=0.16.1.r4.ge9676f81
+pkgrel=1
install=${pkgname%-git}.install
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -18,26 +18,29 @@ sha512sums=('SKIP'
pkgver()
{
- cd "${srcdir}/${pkgname%-git}"
+ cd "${srcdir}/${pkgname%-git}" || exit
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
_pkgname=${pkgname%-git}
-# template start; name=opsu; version=0.2;
+# template start; name=opsu; version=0.3;
pkgdesc="An open source osu!-client written in Java."
arch=('any')
url="https://itdelatrisu.github.io/opsu/"
license=('GPL3')
depends=('java-runtime' 'bash' 'hicolor-icon-theme'
- 'xorg-xrandr' # is a dependency for LWJGL. Had to search around for the fix after the application was throwing an unhandled exception because it couldn't detect monitors. Any chance this could be added to the dep list? - https://aur.archlinux.org/account/SajeOne
+ 'xorg-xrandr' # is a dependency for LWJGL. Had to search around for the fix after the
+ # application was throwing an unhandled exception because it couldn't
+ # detect monitors. Any chance this could be added to the dep list?
+ # https://aur.archlinux.org/account/SajeOne
)
optdepends=('ffmpeg: Background video playback')
makedepends=('java-environment' 'java-web-start' 'gradle' 'git')
build()
{
- cd "${srcdir}/${_pkgname}"
-
+ cd "${srcdir}/${_pkgname}" || exit
+
# keep dependencies outside users home by setting GRADLE_USER_HOME
GRADLE_USER_HOME=. gradle jar -PXDG=true -PexcludeFFmpeg
}
@@ -47,9 +50,16 @@ package()
# cut pkgver
_pkgver=$(git -C "${srcdir}/${_pkgname}" describe --tags | sed 's/-.*//')
- install -Dm644 "${srcdir}/${_pkgname}/build/libs/${_pkgname}-${_pkgver}.jar" "${pkgdir}/usr/share/java/${_pkgname}/${_pkgname}.jar"
- install -Dm644 "${srcdir}/${_pkgname}/res/logo.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
- install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${srcdir}/${_pkgname}/build/libs/${_pkgname}-${_pkgver}.jar" \
+ "${pkgdir}/usr/share/java/${_pkgname}/${_pkgname}.jar"
+
+ install -Dm644 "${srcdir}/${_pkgname}/res/logo.png" \
+ "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
+
+ install -Dm644 "${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ install -Dm755 "${_pkgname}.sh" \
+ "${pkgdir}/usr/bin/${_pkgname}"
}
# template end;