summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Rogoża2017-10-12 22:21:23 +0200
committerPiotr Rogoża2017-10-12 22:21:23 +0200
commitdedcc598a0e3cfd0c227ea461159b5c80d16f92a (patch)
tree18a0e54a68856bc76bbaaf0f1c59dabe3e04e380 /PKGBUILD
parent89e6a84628939073993fe94080861ad5a35d4b59 (diff)
downloadaur-dedcc598a0e3cfd0c227ea461159b5c80d16f92a.tar.gz
Upgraded to 3.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 345ab71b1595..5b59bffcb3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Huguenin Loïs <huguenindl at gmail dot com>
pkgname=oqapy
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc="An application intended to sort files of the image type in graphic mode."
arch=(any)
@@ -18,9 +18,11 @@ python-numpy
gphoto2
dcraw
opencv
+hdf5
)
-source=(http://www.oqapy.eu/releases/$pkgname-$pkgver.tar.gz)
-sha256sums=('c0f5704ff520ea7457d9722a70a3f6127bed48c0bfbf3adf99840f7967950440')
+source=(http://www.oqapy.eu/releases/$pkgname-$pkgver.tar.gz oqapy.sh)
+sha256sums=('6aed4929f7295d94da8f9770225424edd6f7d4ace97e76dd9209872830e0fd20'
+ 'e5bd611647c50b21fb2b1f61801ee45172ee0aa052c3cf15e5e15cf8a0646a27')
package() {
cd "$srcdir"/$pkgname-$pkgver
@@ -36,6 +38,9 @@ package() {
mv $pkgdir/usr/share/oqapy/oqapy.desktop $pkgdir/usr/share/applications/
install -Dm644 $pkgdir/usr/share/oqapy/medias/oqapy_ic_48.png \
"$pkgdir"/usr/share/pixmaps/
- cd "$pkgdir/usr/bin"
- ln -s /usr/share/oqapy/oqapy
+ # workaround for:
+ # Cannot decode file /usr/bin/tgz ...
+ install -Dm755 "$srcdir"/oqapy.sh "$pkgdir"/usr/bin/oqapy
+# cd "$pkgdir/usr/bin"
+# ln -s /usr/share/oqapy/oqapy
}