summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordevninja2017-04-08 11:18:23 -0400
committerdevninja2017-04-08 11:18:23 -0400
commitfe185096aa50ae6998f8e43699445e8b80520c56 (patch)
treeba5bac383084bce17c1b7971a2aad2dda0490d9b /PKGBUILD
downloadaur-fe185096aa50ae6998f8e43699445e8b80520c56.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68b648fecb7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: GI Jack <iamjacksemail@hackermail.com>
+
+# These are bits of odds, ends, and "hacks" for oracle java to obtain feature
+# parity with the openjre packaged by Arch. The main reason for this is no
+# .desktop entry for javaws so oracle's jre as shipped cannot launch java
+# webapps from the browser.
+
+pkgname=oracle-java-extras
+pkgver=1
+pkgrel=1
+pkgdesc="System Entries and intergration for Oracle Java"
+arch=('Any')
+url="http://aur.archlinux.org"
+license=('WTFPL')
+depends=('jre')
+source=("jre_weblaunch.desktop")
+sha256sums=('677a7c574f65ce631070166a8ca53937849815ab88b7c28bc0c5fe604c8bdc9c')
+package() {
+ cd "${srcdir}"
+ install -m644 "jre_weblaunch.desktop" "${pkgdir}/usr/share/applications/jre_weblaunch.desktop"
+}
+