summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFajaryan Wijananto2020-04-23 17:07:59 +0700
committerFajaryan Wijananto2020-04-23 17:07:59 +0700
commit9b4a968b37cb79e51948d026aaf313d42a9b3fc9 (patch)
treeab227b4122190a8bd93142c021af52bfc30b9865 /PKGBUILD
parentea7ae783bfb871c547567374d24bf721fe17378c (diff)
downloadaur-9b4a968b37cb79e51948d026aaf313d42a9b3fc9.tar.gz
Update to 0.8 version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 26 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ac13a3204b2..7ebfc1fb4a8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,42 @@
-# Maintainer: Adolfo silerio
-# Maintainer: Francisco Javier Ospina <francisco.ospina@gmail.com>
+# Maintainer: ryanw
+# Contributor: Adolfo silerio
+# Contributor: Francisco Javier Ospina <francisco.ospina@gmail.com>
pkgname=oranchelo-icon-theme-git
_gitname=oranchelo-icon-theme
-pkgver=v0.7.4
-pkgrel=0
-pkgdesc='Oranchelo is a flat-design icon theme for XFCE4 based on Super Flat Remix and inspired by "Corny icons" by Patryk Goworowski.'
+pkgver=0.8.r6.g13886cb
+pkgrel=1
+pkgdesc='Oranchelo is a flat-design icon theme for XFCE4 based on Super Flat Remix and inspired by "Corny icons" by Patryk Goworowski. (git version)'
arch=(any)
makedepends=('git')
-url='https://github.com/Madh93/oranchelo-icon-theme.git'
+url='https://github.com/OrancheloTeam/oranchelo-icon-theme'
license=('GPL3')
groups=('gnome' 'xfce')
-conflicts=('oranchelo-icon-theme')
+conflicts=('oranchelo-icon-theme')
provides=('oranchelo-icon-theme')
-source=('git+https://github.com/Madh93/oranchelo-icon-theme.git')
+source=("${pkgname}::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- TAG=$(git describe --tags)
- echo $TAG | cut -d"-" -f 1
+ cd ${srcdir}/${_gitname}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
+ install -d -m 755 ${pkgdir}/usr/share/icons/Oranchelo
+ install -d -m 755 ${pkgdir}/usr/share/icons/Oranchelo-Green
+ install -d -m 755 ${pkgdir}/usr/share/icons/Oranchelo-Beka
+ install -d -m 755 ${pkgdir}/usr/share/icons/Oranchelo-Classic-Folders
+ install -d -m 755 ${pkgdir}/usr/share/icons/oranchelo-light
- install -d -m 755 "${pkgdir}/usr/share/icons/Oranchelo"
- install -d -m 755 "${pkgdir}/usr/share/icons/Oranchelo-Green"
-
-
- cd "${srcdir}/${_gitname}/Oranchelo"
- cp -r . "${pkgdir}/usr/share/icons/Oranchelo/"
- cd "${srcdir}/${_gitname}/Oranchelo-Green"
- cp -r . "${pkgdir}/usr/share/icons/Oranchelo-Green/"
+ cd ${srcdir}/${_gitname}/Oranchelo
+ cp -r . ${pkgdir}/usr/share/icons/Oranchelo/
+ cd ${srcdir}/${_gitname}/Oranchelo-Green
+ cp -r . ${pkgdir}/usr/share/icons/Oranchelo-Green/
+ cd ${srcdir}/${_gitname}/Oranchelo-Beka
+ cp -r . ${pkgdir}/usr/share/icons/Oranchelo-Beka/
+ cd ${srcdir}/${_gitname}/Oranchelo-Classic-Folders
+ cp -r . ${pkgdir}/usr/share/icons/Oranchelo-Classic-Folders/
+ cd ${srcdir}/${_gitname}/oranchelo-light
+ cp -r . ${pkgdir}/usr/share/icons/Oranchelo-Light/
}