summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpicokan2020-08-09 11:08:13 +0100
committerpicokan2020-08-09 11:08:13 +0100
commit79c0dd9b23732c0bfc36b6f00fceb36818167db4 (patch)
treec0c84a07e0ef3622b4fb3461176b4f2a5299ac8a /PKGBUILD
parentfed09ef2d01fa09fda40c21b7e24557784d24192 (diff)
downloadaur-orion.tar.gz
Updated source to point to actively maintained repo. Changed PKGBUILD to install license and use the program's Makefile.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f1b406d6601..6f494d471448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainer: Giovanni Harting <539@idlegandalf.com>
+# Maintainer: picokan <todaysoracle@protonmail.com>
+# Contributor: Giovanni Harting <539@idlegandalf.com>
# Contributor: sum01 <sum01@protonmail.com>
# Contributor: David McInnis <davidm@eagles.ewu.edu>
# Contributor: HabarNam <habarnam@gmail.com>
pkgname=orion
pkgver=1.6.7
-pkgrel=1
+pkgrel=2
pkgdesc="QML/C++-written desktop client for Twitch.tv"
arch=('x86_64')
-url="https://github.com/alamminsalo/orion/"
+url="https://github.com/drac69/orion"
license=('GPL3')
depends=('mpv' 'qt5-svg' 'qt5-quickcontrols2' 'qt5-quickcontrols' 'qt5-graphicaleffects')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/alamminsalo/orion/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/drac69/orion/archive/${pkgver}.tar.gz")
sha256sums=('19d9c170d0bcf21d47947704d8c8e927cff5140f94cb840b51d2b8574b0149fb')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
- qmake CONFIG+=mpv
+ mkdir build && cd build
+ qmake ../
make
}
package() {
cd "$srcdir/${pkgname}-${pkgver}"
- install -Dm644 distfiles/orion.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/orion.svg"
- install -Dm644 distfiles/Orion.desktop "${pkgdir}/usr/share/applications/Orion.desktop"
- install -Dm755 orion "${pkgdir}/usr/bin/orion"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
}