diff options
author | acxz | 2021-01-09 21:01:40 -0500 |
---|---|---|
committer | acxz | 2021-01-09 21:01:40 -0500 |
commit | 407ceab77074303170856dd7fd987b4ec2fcc6c8 (patch) | |
tree | f51c6267e1a12fbf4afb37a020fd4c3f515f3778 /PKGBUILD | |
parent | dd4f94e7de1690fb0a5cf8afec3f13478166bb93 (diff) | |
download | aur-407ceab77074303170856dd7fd987b4ec2fcc6c8.tar.gz |
use pybind as backend
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 22 |
1 files changed, 13 insertions, 9 deletions
@@ -2,14 +2,14 @@ # Contributor: Sven Schneider <archlinux.sandmann@googlemail.com> pkgname=orocos-kdl-python-git -pkgver=r931.546d04d -pkgrel=3 +pkgver=r1039.79adc6f +pkgrel=1 pkgdesc="The Kinematics and Dynamics Library is a framework for modelling and computation of kinematic chains (Python binding)" arch=('i686' 'x86_64') url="https://www.orocos.org/kdl" license=('GPL') -depends=(orocos-kdl python-sip) -makedepends=(cmake) +depends=(orocos-kdl python-psutil python-future pybind11) +makedepends=(cmake git) provides=(orocos-kdl-python) conflicts=(orocos-kdl-python) source=(git+https://github.com/orocos/orocos_kinematics_dynamics) @@ -23,18 +23,22 @@ pkgver() { printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } +prepare() { + cd "${srcdir}/${_dir}" + git submodule update --init --recursive +} + build() { cd "${srcdir}/${_dir}/${_pkgname}" - cmake -DCMAKE_INSTALL_PREFIX=/usr \ - -DBUILD_PYKDL_PYBIND11=OFF \ - -DPYTHON_EXECUTABLE=/usr/bin/python \ - . + mkdir -p build && cd build + + cmake -DCMAKE_INSTALL_PREFIX=/usr .. make } package() { - cd "${srcdir}/${_dir}/${_pkgname}" + cd "${srcdir}/${_dir}/${_pkgname}/build" make DESTDIR="${pkgdir}" install } |