summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2020-12-19 16:41:59 -0500
committerGuillaume Horel2020-12-19 16:41:59 -0500
commitf6eaa8c91306ce783231e8155e3dca28b70c0c14 (patch)
tree017231d55e3ff69a92500baaefa8fe66c05a55aa /PKGBUILD
parent1fcd2e2355d46971bce30c8b252a0f701aa29c8a (diff)
downloadaur-ortp-git.tar.gz
cmake cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d29d54412922..9c1ef3aa69c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ortp-git
_pkgname=ortp
-pkgver=4.4.0.alpha.r1.g079d9f1
+pkgver=4.5.0.alpha.r7.g607b2e7
pkgrel=1
pkgdesc="A Real-time Transport Protocol (RTP) library"
arch=('x86_64')
@@ -13,25 +13,25 @@ url="https://github.com/BelledonneCommunications/ortp"
license=('GPL3')
conflicts=('ortp')
provides=("ortp=$pkgver")
-depends=('bctoolbox>=4.3.0')
+depends=('bctoolbox>=4.4.0')
makedepends=('cmake' 'git')
source=("git+https://github.com/BelledonneCommunications/ortp.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
build() {
- cd ${_pkgname}
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_STATIC="NO" \
- -DCMAKE_SKIP_INSTALL_RPATH=ON .
- make
+ cmake -B build "${_pkgname}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_STATIC="NO" \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -Wno-dev
+ make -C build
}
package() {
- cd ${_pkgname}
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" -C build install
}