summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorharre2020-01-04 03:32:57 +0100
committerharre2020-01-04 03:32:57 +0100
commit72fa91812136efc1195b942e4b2427127074109b (patch)
tree6f45fec134b895caf7cdf5a0165aaa5ab6273d31 /PKGBUILD
parent5e66b48fa5b20bc90b48e7eb23d48798ee7cff92 (diff)
downloadaur-72fa91812136efc1195b942e4b2427127074109b.tar.gz
fix .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa5d80a8f619..134949e9f153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
# Contributor: Jason Lenz <Jason@Lenzplace.org>
_pkgname=oscar
pkgname=oscar-git
-pkgver=1.0.r2504.545d48af
+pkgver=1.1.r3041.3be691f2
pkgrel=1
pkgdesc="Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment. Fork of the sleepyhead project."
arch=('i686' 'x86_64')
url="https://gitlab.com/pholy/OSCAR-code"
license=('GPL')
depends=(
- 'qt5-tools'
'qt5-serialport'
)
makedepends=(
@@ -35,6 +34,7 @@ pkgver() {
build() {
cd OSCAR-code
+ git apply ../../permissive.patch
qmake OSCAR_QT.pro
make -j$(cat /proc/cpuinfo | awk '/^processor/{print $3}' | wc -l)
}
@@ -43,6 +43,8 @@ package() {
install -D $srcdir/OSCAR-code/oscar/OSCAR $pkgdir/usr/bin/oscar
install -Dm644 $srcdir/OSCAR-code/oscar/icons/logo-lg.png $pkgdir/usr/share/oscar/icon.png
install -Dm644 $srcdir/oscar.desktop $pkgdir/usr/share/applications/oscar.desktop
+# Where to put translations?
+# install -dDm644 $srcdir/OSCAR-code/Translations $pkgdir/Translations
}
# vim:set ts=2 sw=2 et: