summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjmcb2023-06-21 16:25:06 +0100
committerjmcb2023-06-21 16:25:06 +0100
commitced84b6246d9504eb38519c5ceb33569e8a1fb9b (patch)
treeda636d86cd7c08a5be2f94a2749371858d67cd51 /PKGBUILD
parent15d2056a068309458e6ead32002e8c1d9676a50e (diff)
downloadaur-ced84b6246d9504eb38519c5ceb33569e8a1fb9b.tar.gz
Fix prepare steps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b2186a1d78b..00b630978e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,18 +31,25 @@ pkgver() {
# https://github.com/kritzikratzi/Oscilloscope#compiling-with-make-in-linux
prepare() {
- ln -sf 'of_v0.10.1_linux64gcc6_release' 'OF'
+ # link downloaded openframeworks build to OF and enter it
+ ln -s --force 'of_v0.10.1_linux64gcc6_release' 'OF'
cd OF/apps/myApps
- ln -sf "${srcdir}/${pkgname}" 'Oscilloscope'
+
+ # copy source code into openframeworks and enter it
+ cp -r --update "${srcdir}/${pkgname}" 'Oscilloscope'
cd 'Oscilloscope'
+
+ # clone submodules
git submodule update --init
+
+ # copy addon stuff (from readme instructions)
+ cp -R addons/ofxMightyUI/bin/data/* bin/data/
+ cp -R addons/ofxFontAwesome/bin/data/* bin/data/
}
build() {
cd 'OF/apps/myApps/Oscilloscope'
-
- cp -R addons/ofxMightyUI/bin/data/* bin/data/
- cp -R addons/ofxFontAwesome/bin/data/* bin/data/
+
make
}