summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Squartini2020-02-19 12:33:33 +0900
committerNicola Squartini2020-02-19 12:33:33 +0900
commitdbed8bc8a8f6e048d5fc00bc8eb2c75934ad6e9d (patch)
tree4b8d1c02ec71e5af7bb5265414e287e0691db81b /PKGBUILD
downloadaur-osctl.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d7cda0fc2cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Nicola Squartini <tensor5@gmail.com>
+
+pkgname=osctl
+pkgver=0.3.2
+_commit=fb48851d691d21ab6fc9356a8106b3e498552763
+pkgrel=1
+pkgdesc='A CLI for out-of-band management of Kubernetes nodes created by Talos'
+arch=('i686' 'x86_64')
+url='https://www.talos-systems.com'
+license=('MPL2')
+depends=('glibc')
+makedepends=('git' 'go-pie')
+source=("git+https://github.com/talos-systems/talos.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+build() {
+ cd talos/cmd/osctl
+
+ SHA="${_commit:0:8}"
+ TAG="v${pkgver}"
+ VERSION_PKG='github.com/talos-systems/talos/pkg/version'
+ go build \
+ -ldflags "-extldflags=-Wl,-z,now,-z,relro -s -w -X ${VERSION_PKG}.Name=Client -X ${VERSION_PKG}.SHA=${SHA} -X ${VERSION_PKG}.Tag=${TAG}"
+}
+
+package() {
+ install -Dm755 -t "${pkgdir}/usr/bin" talos/cmd/osctl/osctl
+}