summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-29 21:21:11 +0700
committerVadim Yanitskiy2024-01-29 21:21:11 +0700
commit9911b46f2f4997d3b64b405d841350ca1ea59cb1 (patch)
treebf95fc8b72cb4f91d770455b6418bf25a86903f4 /PKGBUILD
parent7a38ec774c42378d3e65d526984a508d533104fe (diff)
downloadaur-9911b46f2f4997d3b64b405d841350ca1ea59cb1.tar.gz
workaround for missing config files in release tarballs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 384c7014aea4..29c379aabbc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=osmo-bts
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="Osmocom's GSM BTS (Base Transceiver Station) with A-bis/IP interface"
url="https://osmocom.org/projects/osmobts"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
@@ -12,8 +12,21 @@ depends=('libosmocore' 'libosmo-abis' 'libosmo-netif' 'talloc' 'ortp')
conflicts=("${pkgname}-git")
backup=('etc/osmocom/osmo-bts-trx.cfg'
'etc/osmocom/osmo-bts-virtual.cfg')
-source=("https://downloads.osmocom.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('705b5b363aeaffe8cb844fa87242194795cb3747832e01e34355042e21870d5a')
+source=("https://downloads.osmocom.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ "https://cgit.osmocom.org/${pkgname}/plain/doc/examples/trx/osmo-bts-trx.cfg?h=${pkgver}"
+ "https://cgit.osmocom.org/${pkgname}/plain/doc/examples/trx/osmo-bts-trx-calypso.cfg?h=${pkgver}")
+sha256sums=('705b5b363aeaffe8cb844fa87242194795cb3747832e01e34355042e21870d5a'
+ '27158ab5a99345023353ebcef532f1e057cc44e4e50253d6e2d77d8b002f50dc'
+ 'a64771593be92110fcafa5eadbf2b46123fb6077be1e4ff639808f04f9c983fe')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # release tarballs (pkgver <= 1.7.2) are missing some config files
+ # see https://osmocom.org/issues/6349
+ mkdir -p doc/examples/trx
+ cp "${srcdir}/osmo-bts-trx.cfg?h=${pkgver}" doc/examples/trx/osmo-bts-trx.cfg
+ cp "${srcdir}/osmo-bts-trx-calypso.cfg?h=${pkgver}" doc/examples/trx/osmo-bts-trx-calypso.cfg
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"