summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-28 04:57:51 +0700
committerVadim Yanitskiy2024-01-28 04:57:51 +0700
commit6dce9777dced1dae8ea7ad383520491d475aa506 (patch)
tree88b409c564a96a7df01840fd615e5db0f5361911 /PKGBUILD
parent0d4db8e8f9cf1b1ef79a96f55f4b142c63d9aedd (diff)
downloadaur-osmo-ggsn-git.tar.gz
update $pkgver, $provides, $source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ab19156c5da..0e61dd0f90d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=osmo-ggsn-git
-pkgver=1.3.0.r0.gf5a268a
+pkgver=1.11.0.r2.g8d97644
pkgrel=1
pkgdesc="Open Source implementation of a GGSN (Gateway GPRS Support Node)"
url="https://osmocom.org/projects/openggsn"
@@ -9,10 +10,10 @@ arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('libosmocore' 'talloc')
makedepends=('git')
-provides=("${pkgname%-git}")
+provides=('libgtp.so=6-64')
conflicts=("${pkgname%-git}")
backup=('etc/osmocom/osmo-ggsn.cfg')
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +28,9 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
make
}