summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2019-02-07 21:09:26 +0100
committerJosef Miegl2019-02-07 21:09:26 +0100
commit4afda865850dad642e6915bdcd860428a2cc10a9 (patch)
treec83b14113c5f860211a04a92ca9b0a3a551cf875 /PKGBUILD
parent58bbd8d9b93cd3f11f35a0b2ccfc560a2eac8ecb (diff)
downloadaur-4afda865850dad642e6915bdcd860428a2cc10a9.tar.gz
add makedepends, backup, style
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c79f0ab11306..50f395e30285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=osmo-hlr-git
-_pkgname=osmo-hlr
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-pkgver=1.0.0.5.g02078b7
+pkgver=1.0.0.6.gf9cf180
pkgrel=1
-pkgdesc="The Osmocom Home Location Register (OsmoHLR) is the subscriber database and authentication key store of an Osmocom 2G/3G network."
+pkgdesc="Subscriber database and authentication key store of an Osmocom 2G/3G network"
url="https://osmocom.org/projects/osmo-hlr"
-arch=('any')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('libosmocore' 'libosmo-abis' 'sqlite' 'libdbi' 'libdbi-drivers')
-source=("git://git.osmocom.org/${_pkgname}")
+makedepends=('git' 'talloc')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=('etc/osmocom/osmo-hlr.cfg')
+source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- echo $(git describe --always | sed 's/-/./g')
+ cd "${srcdir}/${pkgname%-git}"
+ echo $(git describe --always | sed 's/-/./g')
}
build() {
- cd "${srcdir}/${_pkgname}"
- autoreconf -i
- ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname%-git}"
+ autoreconf -i
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname%-git}"
+ make DESTDIR=${pkgdir} install
}
+
+# vim:set ts=2 sw=2 et: