summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeremy Audet2017-06-25 14:47:05 -0400
committerJeremy Audet2017-06-25 14:48:15 -0400
commit8be9461320917a5a0aea7df4fa196a05342a3bf3 (patch)
treecad721f163a1273ffefdcf3eb42a9a9e91c901e1 /PKGBUILD
parente4cbf24a2a37599c8b01ecf565cdfabb50ccfabb (diff)
downloadaur-8be9461320917a5a0aea7df4fa196a05342a3bf3.tar.gz
Update to version 0.4.4; overhaul package
Most importantly, do the following: * Update package from version 0.4.1 to version 0.4.4. * Don't list glibc as a dependency. [1] * List osmconvert and wget as dependencies. [1] * List gzip as an optional dependency. [1] Also: * Update "maintainer" and "contributor" comments at top of package. * Update the "pkgdesc" variable to be more concise. * Use an "sha256sums" array instead of an "md5sums" array. * Update "license" variable from "GPL" to "AGPL3." * Twiddle with style. Use single quotes instead of double quotes where possible. Drop quotes from especially short and simple strings. Indent function bodies. Add a comment with a vim tabstop and shiftwidth declaration. * Quote variable substitutions. * Enable optimization during compilation. [1] http://wiki.openstreetmap.org/wiki/Osmupdate#Prerequisites
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f9b3d2553b5..f31cb105c191 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Jose Riha <jose1711 [at] gmail (dot) com>
+# Maintainer: Jeremy "Ichimonji10" Audet <ichimonji10 at gmail dot com>
+# Contributor: Jose Riha <jose1711 [at] gmail (dot) com>
pkgname=osmupdate
-pkgver=0.4.1
+pkgver=0.4.4
pkgrel=1
-pkgdesc="a tool to download and cumulate .osc OsmChange files of different categories (minutely, hourly, daily)"
-arch=('i686' 'x86_64')
-url="http://wiki.openstreetmap.org/wiki/Osmupdate"
-license=("gpl")
-depends=('glibc')
-source=("http://m.m.i24.cc/osmupdate.c")
-md5sums=('740162c2400a5e8c78a1bd9a79993242')
+pkgdesc='Download, manipulate and apply OpenStreetMap changefiles'
+url='http://wiki.openstreetmap.org/wiki/Osmupdate'
+license=(AGPL3)
+arch=(i686 x86_64)
+depends=(osmconvert wget)
+optdepends=('gzip: to write gzip compressed files')
+source=('http://m.m.i24.cc/osmupdate.c')
+sha256sums=('54760538cd325efa763a7445d15b4dde140aeafed612f626b31f52a510d6e14c')
build() {
-cd $srcdir
-gcc -oosmupdate osmupdate.c
+ gcc -O3 -oosmupdate osmupdate.c
}
package() {
-install -Dm755 $srcdir/osmupdate $pkgdir/usr/bin/osmupdate
+ install -Dm755 osmupdate "${pkgdir}/usr/bin/osmupdate"
}
+
+# vim:set ts=2 sw=2 et: