summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCong Gu2017-02-28 16:03:22 -0600
committerCong Gu2017-02-28 16:03:22 -0600
commit1e5f6dc5c81eafd3f7e7133e4bde06a0846b83df (patch)
tree741f16ea490906cb1d51ee0fa8a65f5df09ee6ec /PKGBUILD
parente5938f57c5019d92dcfc0e0f191fdf0578afef1d (diff)
downloadaur-1e5f6dc5c81eafd3f7e7133e4bde06a0846b83df.tar.gz
depend libgl; fix sse4.2 config error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0875a646a7f3..f1f80cbe6fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
pkgname=ospray
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Ray Tracing Based Rendering Engine for High-Fidelity Visualization"
arch=('i686' 'x86_64')
url="http://www.ospray.org/"
license=('Apache')
-depends=('qt4>=4.6' 'ispc' 'intel-tbb' 'embree-isa' 'freeglut' 'glu' 'imagemagick')
+depends=('qt4>=4.6' 'ispc' 'intel-tbb' 'embree-isa' 'libgl' 'freeglut' 'glu' 'imagemagick')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ospray/OSPRay/archive/v$pkgver.tar.gz")
-md5sums=('91d88c6e9b0ee5da3eca73a2c77aa019')
-
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ospray/OSPRay/archive/v$pkgver.tar.gz"
+ 'sse4_2.patch')
+md5sums=('91d88c6e9b0ee5da3eca73a2c77aa019'
+ 'cc7a98c9480594afd7db401948e0ceb8')
prepare() {
cd "$srcdir"
[[ -d ${pkgname}-build ]] && rm -r ${pkgname}-build
mkdir ${pkgname}-build
+
+ # issue #129
+ cd ${pkgname}-${pkgver}
+ patch -p1 < ../sse4_2.patch
}
build() {