summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2021-03-07 17:25:28 -0800
committerAnatol Pomozov2021-03-07 17:25:28 -0800
commit015fb3890f0e8b300ae0574fdd5be761f0e4dee6 (patch)
tree1abf1869e931e41d1999ec7033568e8e72834dc1 /PKGBUILD
parent5693ac6b95984d13fca9919d02273b1abb9f48e2 (diff)
downloadaur-015fb3890f0e8b300ae0574fdd5be761f0e4dee6.tar.gz
Initial version of the prebuilt package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb78166a0e6f..9b120431d064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: foi <foi@live.ru>
+# Maintainer: Anatol Pomozov
pkgname=osquery-bin
-pkgver=4.0.2
+pkgver=4.6.0
pkgrel=1
-pkgdesc="osquery is an operating system instrumentation framework."
-arch=('x86_64')
-url="https://osquery.io/"
-license=('Apache License 2.0')
-depends=('glibc' 'bash' 'zlib')
-conflicts=('osquery-git' 'kolide-git')
-sha256sums=('b32f052250908eefabdd582e07aa5e206ab1899762d728bc1a17dae5151070b4')
-source=("https://osquery-packages.s3.amazonaws.com/linux/osquery-${pkgver}_${pkgrel}.linux_x86_64.tar.gz")
+pkgdesc='SQL powered operating system instrumentation, monitoring, and analytics'
+arch=(x86_64)
+url='https://osquery.io'
+license=(Apache, GPL2)
+depends=(zlib)
+makedepends=()
+conflicts=(osquery)
+provides=(osquery)
+replaces=(osquery)
+source=(https://pkg.osquery.io/linux/osquery-${pkgver}_1.linux_x86_64.tar.gz)
+sha1sums=('b73dee6155477c26d77420387fdfd65c9cc73c0b')
package() {
- cp -r etc "$pkgdir/"
- cp -r usr "$pkgdir/"
- cp -r var "$pkgdir/"
-}
-
-post_install() {
- systemctl daemon-reload
+ rm -r etc/init.d
+ cp -r etc $pkgdir
+ cp -r usr/local $pkgdir/usr
+ cp -r var $pkgdir
}