summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfoi2018-03-20 20:55:54 +0700
committerfoi2018-03-20 20:55:54 +0700
commit7a58e74e7330ab4a78d629345fc6c771f6564743 (patch)
tree8fc2f2b5b6b348d469da099f08ae0731164534b5 /PKGBUILD
downloadaur-7a58e74e7330ab4a78d629345fc6c771f6564743.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7224478d6eeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: foi <foi@live.ru>
+
+pkgname=osquery-bin
+pkgver=2.11.2
+pkgrel=1
+pkgdesc="osquery is an operating system instrumentation framework."
+arch=('x86_64')
+url="https://osquery.io/"
+license=('Apache License 2.0')
+provides=('osquery-git' 'kolide-git')
+depends=('glibc' 'bash' 'zlib')
+conflicts=('osquery-git' 'kolide-git')
+sha256sums=('6b9f032bf04a0a938c4cd2a7f24f0f4fef1aca8593661f3801822760b178fdbd')
+source=("https://osquery-packages.s3.amazonaws.com/linux/osquery-${pkgver}_${pkgrel}.linux_x86_64.tar.gz")
+
+package() {
+ cp -r etc "$pkgdir/"
+ cp -r usr "$pkgdir/"
+ cp -r var "$pkgdir/"
+}
+
+post_install() {
+ systemctl daemon-reload
+}