summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2016-07-17 21:39:00 -0400
committerTony Lambiris2016-07-17 21:39:00 -0400
commit45c888a20b84796ecb6ee7f94a0552d997ee3531 (patch)
tree4ba1dc95ed9d452760284bbe11e09402adefd89e /PKGBUILD
parent437de54e0584fd04cdfe5f3eb2ccd40b195758b1 (diff)
downloadaur-45c888a20b84796ecb6ee7f94a0552d997ee3531.tar.gz
Add python deps, streamline compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 933f461d3c5e..a99966674e81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,14 @@ groups=()
depends=('asio' 'audit' 'aws-sdk-cpp-git' 'boost' 'boost-libs' 'clang' 'cmake'
'doxygen' 'gflags' 'git' 'google-glog' 'lsb-release' 'make' 'python'
'python-jinja' 'python-pip' 'sleuthkit' 'snappy' 'thrift' 'yara')
-makedepends=('rocksdb' 'rocksdb-static' 'cpp-netlib' 'magic' 'unzip')
+makedepends=('python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb'
+ 'rocksdb-static' 'cpp-netlib' 'magic' 'unzip' 'wget')
checkdepends=()
optdepends=()
provides=()
conflicts=()
replaces=()
-backup=()
+backup=('etc/osquery/osquery.conf')
options=()
install=
changelog=
@@ -31,8 +32,8 @@ source=("${pkgname}-${pkgver}::git+https://github.com/facebook/osquery"
"arch-linux.patch")
noextract=()
sha256sums=('SKIP'
- '6f1d7950f547ba6e39a67a267c0a8a46424dd9707cec9041a95fb75fc35a3dcf'
- '8da0d77bd189f4bb778a6be719322ea8c0cd624d2ad3e76bee584bd1d1259542')
+ '1fa367325d4a7ad7dfef3b7b817b3c7588ad02a8d08fc11db24de66b486c6503'
+ '745e4561eb065d05826d8f96d1cd06640463a5a85f38d2581ea85d2e33fd8d24')
validpgpkeys=()
_gitname=${pkgname}-${pkgver}
@@ -50,13 +51,12 @@ prepare() {
patch -p1 -i "${srcdir}/arch-linux.patch"
}
-
build() {
cd $_gitname
make deps
- cmake -DCMAKE_INSTALL_PREFIX=/usr
- make -j $(nproc) -C osquery DESTDIR="${pkgdir}"
+ cmake -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr
+ make -j $(nproc)
}
package() {