summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2016-07-17 21:59:41 -0400
committerTony Lambiris2016-07-17 21:59:41 -0400
commitab69deffe64d0c681b8683cd0d5d635381694720 (patch)
tree7563e5dfb08fb8efcf448776c9cfca3e964cf695 /PKGBUILD
parent45c888a20b84796ecb6ee7f94a0552d997ee3531 (diff)
downloadaur-ab69deffe64d0c681b8683cd0d5d635381694720.tar.gz
Version update, remove version from _gitname var
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 24 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a99966674e81..660faa10e1c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Matěj Týč <matej.tyc@gmail.com>
pkgname=osquery-git
-pkgver=1.8.0.r3.gb9a5313
+pkgver=1.8.0.r4.gc1d004e
pkgrel=1
epoch=
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
@@ -14,8 +14,8 @@ url="https://osquery.io"
license=('BSD')
groups=()
depends=('asio' 'audit' 'aws-sdk-cpp-git' 'boost' 'boost-libs' 'clang' 'cmake'
- 'doxygen' 'gflags' 'git' 'google-glog' 'lsb-release' 'make' 'python'
- 'python-jinja' 'python-pip' 'sleuthkit' 'snappy' 'thrift' 'yara')
+ 'doxygen' 'gflags' 'git' 'google-glog' 'lsb-release' 'make' 'python'
+ 'python-jinja' 'python-pip' 'sleuthkit' 'snappy' 'thrift' 'yara')
makedepends=('python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb'
'rocksdb-static' 'cpp-netlib' 'magic' 'unzip' 'wget')
checkdepends=()
@@ -27,49 +27,49 @@ backup=('etc/osquery/osquery.conf')
options=()
install=
changelog=
-source=("${pkgname}-${pkgver}::git+https://github.com/facebook/osquery"
- "osqueryd.service"
- "arch-linux.patch")
+source=("${pkgname}::git+https://github.com/facebook/osquery"
+ "osqueryd.service"
+ "arch-linux.patch")
noextract=()
sha256sums=('SKIP'
'1fa367325d4a7ad7dfef3b7b817b3c7588ad02a8d08fc11db24de66b486c6503'
'745e4561eb065d05826d8f96d1cd06640463a5a85f38d2581ea85d2e33fd8d24')
validpgpkeys=()
-_gitname=${pkgname}-${pkgver}
+_gitname=${pkgname}
pkgver() {
- cd $_gitname
+ cd $_gitname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $_gitname
+ cd $_gitname
- git submodule update --init
- patch -p1 -i "${srcdir}/arch-linux.patch"
+ git submodule update --init
+ patch -p1 -i "${srcdir}/arch-linux.patch"
}
build() {
- cd $_gitname
+ cd $_gitname
- make deps
- cmake -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr
- make -j $(nproc)
+ make deps
+ cmake -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr
+ make -j $(nproc)
}
package() {
- cd $_gitname
+ cd $_gitname
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
- install -dm755 "${pkgdir}/var/osquery/"
- install -dm755 "${pkgdir}/var/log/osquery/"
+ install -dm755 "${pkgdir}/var/osquery/"
+ install -dm755 "${pkgdir}/var/log/osquery/"
- install -Dm755 "${pkgdir}/usr/share/osquery/osquery.example.conf" \
- "${pkgdir}/etc/osquery/osquery.conf"
+ install -Dm755 "${pkgdir}/usr/share/osquery/osquery.example.conf" \
+ "${pkgdir}/etc/osquery/osquery.conf"
- install -Dm755 "${srcdir}/osqueryd.service" \
- "${pkgdir}/usr/lib/systemd/system/osqueryd.service"
+ install -Dm755 "${srcdir}/osqueryd.service" \
+ "${pkgdir}/usr/lib/systemd/system/osqueryd.service"
}