summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2016-07-31 16:52:33 -0400
committerTony Lambiris2016-07-31 16:52:33 -0400
commite5ef7464fbfef596330579a1097727855302f79d (patch)
tree15203d9c1401321de66a5e934c4913af0f7a0db1 /PKGBUILD
parentab69deffe64d0c681b8683cd0d5d635381694720 (diff)
downloadaur-e5ef7464fbfef596330579a1097727855302f79d.tar.gz
Set good commitish until arch provisions natively
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 660faa10e1c6..7c1c2e6dfd2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,16 +37,19 @@ sha256sums=('SKIP'
validpgpkeys=()
_gitname=${pkgname}
+# last known working commit-ish
+_githash=c1d004ed1f12a4113102fafd0c633001b8e4254c
pkgver() {
cd $_gitname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags $_githash | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd $_gitname
+ git checkout $_githash
git submodule update --init
patch -p1 -i "${srcdir}/arch-linux.patch"
}