summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTC2017-09-13 00:54:46 -0700
committerTC2017-09-13 00:54:46 -0700
commit78774bb21918f64666e2ee8372aa62a024027e94 (patch)
tree1459386807ab8df41e553893c6e4b5ac9da70d5e /PKGBUILD
parent5a93948e7fdaad4c2094b02fe533b009c6787914 (diff)
downloadaur-78774bb21918f64666e2ee8372aa62a024027e94.tar.gz
create $pkgdir/etc and USER_DIR="$pkgdir/$_instdir" for install.sh
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 958a8b3bef95..4f0908a3b6cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,10 +34,6 @@ build() {
# fix placement of ossec-init.conf
sed -i "s|^OSSEC_INIT.*|OSSEC_INIT=\"$pkgdir/etc/ossec-init.conf\"|" src/init/shared.sh
-
-cd src
-make all
-make build
}
package() {
@@ -46,9 +42,8 @@ package() {
_preparevars
. "$srcdir/config" # load configuration
- install -d "$pkgdir/etc"
-
- ./install.sh
+ mkdir -p $pkgdir/etc
+ USER_DIR="$pkgdir/$_instdir" ./install.sh
# install systemd service unit
install -Dm0644 "$srcdir/ossec.service" "$pkgdir/usr/lib/systemd/system/ossec.service"