summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTC2017-09-12 23:46:30 -0700
committerTC2017-09-12 23:46:30 -0700
commit9e403536ecd3034e23b6b9922a72677225bb7e6b (patch)
tree264c103f2dfb0560da6052f48f79097b2043c5c0 /PKGBUILD
parent90d9869419de36fefe8d5d457c1125a88f8f213a (diff)
downloadaur-9e403536ecd3034e23b6b9922a72677225bb7e6b.tar.gz
try to clean and update a bit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f907e36496ee..9280eb8f300c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,11 @@ backup=('var/ossec/etc/ossec.conf')
install=ossec.install
options=('emptydirs')
source=(https://github.com/ossec/$pkgname/archive/$pkgver.tar.gz \
- ossec.service
+ ossec.service
config)
sha256sums=('ed5bc3483d5e864a8f8283f57127d1251b458c184e5b263be8be4c89f4cf85c3'
'be5f6fe7e10603a0897c2502e0e6913fbb544a66f59674aaaef87d0f31d09eb9'
- 'bf47f0919a2470f199cf731e68063939a59a31541c0ae3ebe87a561760f5f3f2')
+ '372b4584093204f37a9cdeb6df5f7dc1a7f88873adc15f8b7de68d0378f2edf8')
_instdir=/var/ossec
@@ -42,17 +42,17 @@ package() {
_preparevars
. "$srcdir/config" # load configuration
- mkdir -p $pkgdir/etc
-
./install.sh
- # install systemd service
- install -Dm0644 "$srcdir"/ossec.service "$pkgdir"/usr/lib/systemd/system/ossec.service
+ # install systemd service unit
+ install -Dm0644 "$srcdir/ossec.service" "$pkgdir/usr/lib/systemd/system/ossec.service"
+ # install license
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/ossec-hids/LICENSE
- # change the users
+ # change user permissions
find "$pkgdir" -user nobody -exec chown 524 '{}' ';'
find "$pkgdir" -user mail -exec chown 525 '{}' ';'
find "$pkgdir" -user daemon -exec chown 526 '{}' ';'
- # change the groups
+ # change group permissions
find "$pkgdir" -group nobody -exec chgrp 525 '{}' ';'
}