summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:04:03 +0200
committerM0Rf302015-06-17 16:04:03 +0200
commit545d7b971f1016ffefaf989cf672f8b51aeccb31 (patch)
tree6814bcfb46e3cee5294120dcc2313df7848ab523 /PKGBUILD
downloadaur-545d7b971f1016ffefaf989cf672f8b51aeccb31.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b35035c2843
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: M0Rf30
+
+pkgname=ostinato
+pkgver=0.6
+pkgrel=1
+url="http://code.google.com/p/ostinato/"
+pkgdesc="Cross-platform network packet/traffic generator and analyzer"
+source=("http://dl.bintray.com/pstavirs/ostinato/ostinato-src-$pkgver.tar.gz")
+arch=('i686' 'x86_64')
+depends=('protobuf' 'qt4' 'libpcap')
+optdepends=('wireshark' 'tshark' 'gzip' 'diff' 'awk')
+license=(GPL)
+
+build(){
+ cd $srcdir/$pkgname-$pkgver
+ qmake-qt4 PREFIX=$pkgdir/usr
+ make
+}
+
+package(){
+ cd $srcdir/$pkgname-$pkgver
+ make install
+}
+
+md5sums=('0e6f825179ab01b77f00042172afe921')