summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormorguldir2018-11-22 15:49:29 +0100
committermorguldir2018-11-22 15:49:29 +0100
commite8413d6e33f786d90ee4ef48f09a0f02e7404aef (patch)
tree7c12ee1593e7b12e95c4a19ca57b9c06cdf88054 /PKGBUILD
parent76fa5c2c00ae01008c903ba4791933ded29ee6b9 (diff)
downloadaur-e8413d6e33f786d90ee4ef48f09a0f02e7404aef.tar.gz
Include libraries in package to avoid depending them being in ~/nuget
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5723ca86ea79..2fcd02f2fd8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=osu-lazer
pkgver=2018.1120.0
-pkgrel=1
+pkgrel=2
pkgdesc="The new open source version of osu!, the free-to-win rhythm game"
arch=('x86_64')
license=('MIT' 'custom:CC-BY-NC 4.0')
@@ -45,10 +45,12 @@ build()
{
cd "osu-$pkgver"
- dotnet build \
- osu.Desktop \
- --framework netcoreapp2.1 \
- --configuration Release
+ dotnet publish osu.Desktop \
+ --framework netcoreapp2.1 \
+ --configuration Release \
+ --runtime linux-x64 \
+ --self-contained false \
+ --output ./bin/Release/netcoreapp2.1/linux-x64
}
package()
@@ -71,7 +73,7 @@ package()
install -m644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
# Compiled binaries
- cd "$srcdir/osu-$pkgver/osu.Desktop/bin/Release/netcoreapp2.1"
+ cd "$srcdir/osu-$pkgver/osu.Desktop/bin/Release/netcoreapp2.1/linux-x64"
mkdir -p "$pkgdir/usr/lib/$pkgname"
for binary in *.so *.dll *.json *.pdb; do
install -m755 "$binary" "$pkgdir/usr/lib/$pkgname/$binary"