diff options
author | Ammon Smith | 2017-09-21 01:13:39 -0700 |
---|---|---|
committer | Ammon Smith | 2017-09-21 01:13:39 -0700 |
commit | 224c16162b7a6cf84a989f77ff0698204b68e3a2 (patch) | |
tree | 6607cdc3229b0f7a7ab0c172633f95488c9063d2 /PKGBUILD | |
parent | b70e8eb1ead316a881128ae03fb5c669dd6ca442 (diff) | |
download | aur-224c16162b7a6cf84a989f77ff0698204b68e3a2.tar.gz |
Add hack to fix nuget OpenTK issue.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -2,7 +2,7 @@ # Contributor: Nicole Fontenot <nfontenot27@gmail.com> pkgname=osu-lazer-git -pkgver=2017.825.0_40_g2742fe46 +pkgver=2017.919.0_2_g278e51eeb pkgrel=1 pkgdesc='Freeware rhythm video game - lazer development version' arch=('x86_64' 'i686') @@ -49,6 +49,11 @@ build() { git submodule init git submodule update --recursive + # HACK: OpenTK dependency that nuget can't find + wget \ + -O "$HOME/.local/share/NuGet/Cache/OpenTK.3.0.0-git00009.nupkg" \ + 'https://www.myget.org/F/opentk-develop/api/v2/package/OpenTK/3.0.0-git00009' + # Download dependencies nuget restore @@ -75,7 +80,7 @@ package() { install -m644 "${pkgname%-git}.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png" # Compiled binaries - cd "$srcdir/osu/osu.Desktop/bin/Release" + cd "$srcdir/osu/osu.Game/bin/Release" mkdir -p "$pkgdir/usr/lib/${pkgname%-git}" for binary in *.exe *.dll; do install -m755 "$binary" "$pkgdir/usr/lib/${pkgname%-git}/$binary" |