summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcainy-a2021-03-21 14:21:55 +0000
committercainy-a2021-03-21 14:22:07 +0000
commit7edb61c45f30c9d0bf223eb8a33e4e034b4f121a (patch)
tree18eeed0d4f81a5cbb875fd85871fc5840724f731 /PKGBUILD
downloadaur-osu-tunes-git.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..931f6dd7d44c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Cain Atkinson <yellowsink@protonmail.com>
+
+_pkgname="osu-tunes"
+pkgname="${_pkgname}-git"
+pkgver=r5.9c18074
+pkgrel=1
+pkgdesc="An audio player using osu! beatmaps"
+arch=('x86_64')
+url="https://github.com/cainy-a/osu-tunes"
+license=('BSD')
+groups=()
+depends=('csfml')
+makedepends=('git' 'nim' 'nimble' 'clang')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+backup=("usr/share/${_pkgname}/data")
+source=("${_pkgname}-source::git+${url}#commit=9c18074b50e78f5977e34c20863b9fe602fd56ae")
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+prepare() {
+ cd "$srcdir/${pkgname%-VCS}"
+ patch -p1 -i "$srcdir/${pkgname%-VCS}.patch"
+}
+
+pkgver() {
+ cd "${_pkgname}-source"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # install deps
+ nimble install csfml zip
+}
+
+build() {
+ cd "${_pkgname}-source"
+
+ # build with nim
+ nim c -d:ssl OsuTunes.nim
+}
+
+#check() {
+# cd "$srcdir/${pkgname%-VCS}"
+# make -k check
+#}
+
+package() {
+ cd "${_pkgname}-source"
+
+ # install license
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+
+ # install built binary
+ install -Dm 755 "OsuTunes" "${pkgdir}/usr/bin/${_pkgname}"
+}