summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-12-13 15:33:21 -0800
committerxiota2023-12-13 15:33:42 -0800
commitfd2951069e66d17eb8e0b9357ef1287f32778fcd (patch)
treed3bdaf9e8772bb000567a682c14fe1c384a544fb /PKGBUILD
parent887ad6737f88673eb237609ba305042054a6934e (diff)
downloadaur-osu-wine-git.tar.gz
metapackage
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 5 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd534054d19b..5d79e3798865 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,12 @@
# Maintainer:
-# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
-_pkgname="osu-wine"
-pkgname="$_pkgname-git"
-pkgver=1.0.r2.g062ad51
+_newpkg='osu-lazer'
+pkgname='osu-wine-git'
+pkgver=1.1
pkgrel=1
-pkgdesc="osu!"
-url="https://github.com/Nefelim4ag/osu-wine"
-license=('GPL3')
+pkgdesc="metapackage - migrate to $_newpkg"
arch=('any')
-makedepends=('git')
-optdepends=(
- 'lib32-libpulse: for audio'
- 'lib32-gnutls'
-)
-
-_pkgsrc="$_pkgname"
-source=("$_pkgsrc"::"git+$url.git")
-sha256sums=('SKIP')
-
-install="$pkgname.install"
-backup=("etc/osu-wine.conf")
-
-pkgver() {
- cd "$_pkgsrc"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
package() {
- depends+=(
- 'bash'
- 'hicolor-icon-theme'
- 'wget'
- 'wine'
- 'winetricks'
- )
-
- cd "$_pkgsrc"
- make install PREFIX="$pkgdir"
+ depends=("$_newpkg")
}