summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbbb6512021-09-18 15:37:03 +0300
committerbbb6512021-09-18 15:37:03 +0300
commit900f65b41bfd4bd587fe72d005c0a79bcda67081 (patch)
tree68608ba123263ee51530aecc571d996d2069237c /PKGBUILD
downloadaur-osume-git.tar.gz
Added PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8d84575a067
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bar Yemini <bar.ye651@gmail.com>
+pkgname=osume-git
+_pkgname=${pkgname%-git}
+pkgver=0.1.0.r1.g2d06485
+pkgrel=1
+pkgdesc="Extract music from osu!lazer beatmaps"
+url="https://github.com/bbb651/${_pkgname}"
+arch=('any')
+license=('GPL3')
+depends=('python' 'python-mutagen' 'python-inquirer' 'python-tqdm')
+makedepends=('git')
+conflicts=("${_pkgname}")
+source=("$_pkgname::git+https://github.com/bbb651/$_pkgname.git#branch=main")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ local _version="$(git describe --long --tags | sed -e 's/-/.r/' -e 's/-/./')"
+ printf "${_version#v}"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 osume.py "$pkgdir/usr/bin/osume"
+}