summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Haag2020-07-24 03:34:40 +0200
committerChristoph Haag2020-07-24 04:24:08 +0200
commit3526ce92d27304ed83c7a788c13cd324e5b94e02 (patch)
treecf46a87df9b4989553176f3ea56ac8dc4333db40 /PKGBUILD
parent6c47c947f8cd4da634a2d21dfa658bfdc23d7fb4 (diff)
downloadaur-osvr-rendermanager-git.tar.gz
remove patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 3 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a35af616256a..7166220bff35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=osvr-rendermanager-git
-pkgver=v00_06_52.r312.g32bb995
+pkgver=v00_06_52.r350.g56f9db6
pkgrel=1
pkgdesc="TW, ATW and high performance rendering with OpenGL and GLES"
arch=(i686 x86_64)
@@ -9,11 +9,9 @@ url="https://github.com/sensics/OSVR-RenderManager"
makedepends=('git' 'cmake')
depends=('osvr-core-git' 'eigen') #TODO: add more deps
source=("osvr-rendermanager::git+https://github.com/sensics/OSVR-RenderManager.git"
- "vendor-vrpn::git+https://github.com/vrpn/vrpn.git"
- "use_core_profile_unconditionally.diff")
+ "vendor-vrpn::git+https://github.com/vrpn/vrpn.git")
md5sums=('SKIP'
- 'SKIP'
- '4f58517e2c39fd486f84b34afe7d07ad')
+ 'SKIP')
pkgver() {
cd "$srcdir/osvr-rendermanager"
@@ -37,27 +35,6 @@ prepare() {
# this copies over osvr-core files from the system into the install directory so they would simply be overwritten in /usr/lib
sed -i "/osvrrm_copy_deps(osvr::osvrClientKit osvr::osvrClient osvr::osvrCommon osvr::osvrUtil)/d" CMakeLists.txt
-
- echo
- echo "Patch Rendermanager to use an OpenGL Core Profile?"
- echo "For mesa drivers you should say Y, for proprietary drivers you should say n."
- echo "(Some of the example programs will not work with a Core Profile, this is not a rendermanagager bug, but a result of this patch)"
- echo "For more information refer to"
- echo "https://github.com/sensics/OSVR-RenderManager/issues/68"
- echo "https://github.com/sensics/OSVR-RenderManager/issues/233"
- read -p "[Y/n]? " -n 1 -r
- echo # (optional) move to a new line
- case "$REPLY" in
- y*|Y*|"" )
- echo "Patching rendermanager to use a core profile..."
- git apply -vvv "$srcdir"/use_core_profile_unconditionally.diff
- echo "Patched..."
- ;;
- * )
- echo "Building unpatched..."
- ;;
- esac
- sleep 1
}
build() {