summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Haag2017-03-10 04:04:34 +0100
committerChristoph Haag2017-03-10 04:04:34 +0100
commit64a8d2f4417b8c7e9b7805f800f9f566f5a83c1c (patch)
tree64ce614ba053f321d3a9944c3560dc1fe9c42cb4 /PKGBUILD
parentd274d5ec85c91f6f94a1ff345d298d9cbcbbe041 (diff)
downloadaur-64a8d2f4417b8c7e9b7805f800f9f566f5a83c1c.tar.gz
update-v1.0.6 branch works now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51943edd3fca..2fbaf974f123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=osvr-steamvr-git
-pkgver=v0.1.r296.g7011d81
+pkgver=v0.1.r300.gce5ebed
pkgrel=1
pkgdesc="Driver for allowing applications written against SteamVR to work with hardware and software running with the OSVR software framework."
arch=(i686 x86_64)
@@ -9,8 +9,9 @@ install=osvr-steamvr.install
makedepends=('git' 'cmake')
depends=('osvr-core-git' 'openvr-git' 'osvr-rendermanager-git') #TODO: add more deps
conflicts=('osvr-display-git')
-source=("osvr-steamvr::git+https://github.com/OSVR/SteamVR-OSVR.git" #TODO: remove when it is merged
+source=("osvr-steamvr::git+https://github.com/OSVR/SteamVR-OSVR.git#branch=update-v1.0.6" #TODO: remove when it is merged
"Findjsoncpp.cmake")
+#options=('!strip')
pkgver() {
cd "$srcdir/osvr-steamvr"
@@ -52,6 +53,10 @@ package() {
rm -f "$pkgdir"/usr/lib/libgmock_main.a
rm -f "$pkgdir"/usr/lib/libgtest.a
rm -f "$pkgdir"/usr/lib/libgtest_main.a
+ rm -rf "$pkgdir"/usr/include/docopt/
+ rm -rf "$pkgdir"/usr/lib/cmake/
+ rm -f "$pkgdir"/usr/lib/libdocopt.a
+ rm -f "$pkgdir"/usr/lib/libdocopt.so
}
md5sums=('SKIP'
'2dd82e55b6291d32c611dd899d8a8164')