summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororumin2016-05-14 13:23:51 +0900
committerorumin2016-05-14 13:23:51 +0900
commit3dfd3245470a458c462fbf91ae434d27253d2b42 (patch)
treeec6cdebe6570f08d5aadd3920515aa8f11def704 /PKGBUILD
downloadaur-3dfd3245470a458c462fbf91ae434d27253d2b42.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bb78db24346
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: orumin <dev@orum.in>
+
+_gitname=OS-X-El-Capitan
+pkgname=osx-el-capitan-theme-git
+pkgdesc="Theme mimics OS X 10.11 El Capitan for GTK3 and some DEs (GNOME Shell, Xfce, Cinnamon)"
+pkgver=v0.7.r0.g9bf29e5
+pkgrel=1
+arch=('any')
+url="https://github.com/Elbullazul/${_gitname}"
+source=("git+${url}")
+depends=('gtk-engine-murrine' 'gtk-engine')
+makedepends=('git')
+optdepends=('gnome-themes-standard: Required for the GTK3 theme')
+license=('GPL3')
+conflicts=('gnome-shell-theme-osx-el-capitan')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ find */ -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
+}