summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSwyter2023-04-25 06:30:51 +0200
committerSwyter2023-04-25 06:30:51 +0200
commit3dc53396f8c47868eb6e3e283e5a84b6db49a0eb (patch)
treeded8029a8e016dfb3acdaec6e47e22f6fac631f8 /PKGBUILD
parent65c9d5447078a46353c58f33db14b060bb235ff5 (diff)
downloadaur-3dc53396f8c47868eb6e3e283e5a84b6db49a0eb.tar.gz
Merge the changes kindly provided by Amavect. Adding the workaround for the #108 issue and modularizing the SDK version instead of hardcoding it. Many thanks!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a73e50528ece..28947e51b9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,37 @@
# Maintainer: swyter <swyterzone+aur@gmail.com>
pkgname=osxcross-git
_pkgname=${pkgname%-git}
+_sdkname=MacOSX10.11.sdk # swy: choose your SDK version here
pkgver=0.15
pkgrel=1
-pkgdesc="OS X cross toolchain for Linux, FreeBSD and NetBSD"
+pkgdesc="macOS cross-compiling toolchain for Linux, FreeBSD and NetBSD"
arch=('x86_64')
url="https://github.com/tpoechtrager/osxcross"
license=('MIT')
-depends=()
-makedepends=('clang>=3.2' 'patch' 'libxml2' 'bash')
+depends=('clang>=3.2')
+makedepends=('patch' 'libxml2' 'bash')
optdepends=(
'llvm: for Link Time Optimization support and ld64 -bitcode_bundle support'
'uuid: for ld64 -random_uuid support'
'xar: for ld64 -bitcode_bundle support'
)
-provides=("$_pkgname" "xar")
-conflicts=("$_pkgname" "xar")
-source=('git+https://github.com/tpoechtrager/osxcross.git' 'https://s3.dockerproject.org/darwin/v2/MacOSX10.11.sdk.tar.xz')
+provides=("$_pkgname" xar)
+conflicts=("$_pkgname" xar apple-darwin-osxcross)
+source=(
+ 'git+https://github.com/tpoechtrager/osxcross.git'
+ "https://s3.dockerproject.org/darwin/v2/${_sdkname}.tar.xz"
+)
md5sums=('SKIP' 'b0d81b95746c7e698c39c7df1e15ca7d')
-noextract=('MacOSX10.11.sdk.tar.xz')
+noextract=("${_sdkname}.tar.xz")
options=('!strip')
install="$pkgname.install"
+# https://github.com/tpoechtrager/cctools-port/issues/108
+CXXFLAGS="$CXXFLAGS -U_GLIBCXX_ASSERTIONS -Wp,-U_GLIBCXX_ASSERTIONS"
+
prepare() {
cd "$srcdir/$_pkgname"
- mv ../MacOSX10.11.sdk.tar.xz tarballs/
+ mv "../${_sdkname}.tar.xz" tarballs/
}
build() {