summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonard König2021-03-31 20:20:22 +0200
committerLeonard König2021-03-31 20:20:22 +0200
commit8e58ff863bd7c49356ebe7ef8ca40abe837d9818 (patch)
tree2f7eb3865486d940c076e8cd235b98dff6d24215 /PKGBUILD
parent864e5c57be5daeaa895e6aaa9fdf04351f09a770 (diff)
downloadaur-8e58ff863bd7c49356ebe7ef8ca40abe837d9818.tar.gz
changes for Apple New York family
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a895e1415750..732ab8757e35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Leonard Janis König <ljrk@ljrk.org>
-pkgname='otf-apple-sf-mono'
-pkgver=16.0d2e1
+pkgname='otf-apple-ny'
+pkgver=16.0d2e2
pkgrel=1
-pkgdesc='Apples monospaced vairant of the San Francisco typeface family.'
+pkgdesc='Apples New York typeface family. For usage alongside SF.'
arch=('any')
url='https://developer.apple.com/fonts/'
license=('custom:apple-restricted-font')
-source=('https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg'
+source=('https://devimages-cdn.apple.com/design/resources/download/NY-Font.dmg'
'license.awk'
'version.awk')
-sha256sums=('fc0beba1460fbe0f1f6d7c0f1eff6e09dd9cd996a24595f47dcb332614ecd541'
+sha256sums=('58058b5dbddb77eec84a0c0b10b41fc544bc7cd50c6cb49874da4197f91afde5'
'cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889'
'55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198')
makedepends=('texlive-bin' 'p7zip')
@@ -18,17 +18,17 @@ makedepends=('texlive-bin' 'p7zip')
prepare() {
cd ${srcdir}
# These are dmg images, xar and cpio archives. Just use 7z.
- 7z x -y 'SF-Mono.dmg'
- 7z x -y 'SFMonoFonts/SF Mono Fonts.pkg'
+ 7z x -y 'NY-Font.dmg'
+ 7z x -y 'NYFonts/NY Fonts.pkg'
7z x -y 'Payload~'
- otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/NewYorkMedium-Regular.otf | \
awk -f license.awk > LICENSE
}
pkgver() {
cd ${srcdir}
- otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/NewYorkMedium-Regular.otf | \
awk -f version.awk
}