summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonard Janis Robert König2021-07-02 02:05:15 +0200
committerLeonard Janis Robert König2021-07-02 02:05:15 +0200
commit707b41e38783b6bac193cc3d5cab9c1955c54267 (patch)
treec1d9ff72e5618340aeb809228e358793e634f5d4 /PKGBUILD
parentda9fe1b324df3b62f391107a482425af35922b00 (diff)
downloadaur-707b41e38783b6bac193cc3d5cab9c1955c54267.tar.gz
Apple SF Arabic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4f4b5a6adcc..7d9d1aeb8541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
# Maintainer: Leonard Janis König <ljrk@ljrk.org>
-pkgname='otf-apple-sf-pro'
-pkgver=17.0d9e1
+pkgname='otf-apple-sf-arabic'
+pkgver=17.0d8e2
pkgrel=1
-pkgdesc='Apples San Francisco typeface family. System font.'
+pkgdesc='Apples San Francisco typeface family. Arabic font.'
arch=('any')
url='https://developer.apple.com/fonts/'
license=('custom:apple-restricted-font')
-_file='SF-Pro.dmg'
+_file='SF-Arabic.dmg'
source=("https://devimages-cdn.apple.com/design/resources/download/$_file"
'license.awk'
'version.awk')
-sha256sums=('3faf431f1fd5d0da03708ea3ad976585ba63add1e8f031064fedb28398d8c3f3'
+sha256sums=('5b28d2c7ec5573375aa5e4ac5c4b3c48aad86f48a559af96e848b448422abb12'
'cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889'
- '55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198')
+ 'cc3460cf67bde420b2b43f26d80ff4d98bd64b9f65e7c66856d7422ffbcd0945')
makedepends=('texlive-bin' 'p7zip')
prepare() {
cd ${srcdir}
# These are dmg images, xar and cpio archives. Just use 7z.
7z x -y "$_file"
- 7z x -y 'SanFranciscoPro/San Francisco Pro.pkg'
+ 7z x -y 'SFArabicFonts/SF Arabic Fonts.pkg'
7z x -y 'Payload~'
- otfinfo -i Library/Fonts/SF-Pro-Display-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/SF-Arabic.ttf | \
awk -f license.awk > LICENSE
}
pkgver() {
cd ${srcdir}
- otfinfo -i Library/Fonts/SF-Pro-Display-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/SF-Arabic.ttf | \
awk -f version.awk
}
package() {
- install -Dm655 "${srcdir}"/Library/Fonts/*.otf \
- -t "${pkgdir}/usr/share/fonts/OTF/"
+ install -Dm655 "${srcdir}"/Library/Fonts/*.ttf \
+ -t "${pkgdir}/usr/share/fonts/TTF/"
install -Dm644 LICENSE \
"${pkgdir}"/usr/share/licenses/${pkgname}/AppleFontLicense
}