summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonard König2021-03-31 20:22:01 +0200
committerLeonard König2021-03-31 20:22:01 +0200
commita58102350ce5dc3bd9f83aadbaadad33d157948a (patch)
tree1f16f66dd8135e9061cd79329b2321b47549d47d /PKGBUILD
parent864e5c57be5daeaa895e6aaa9fdf04351f09a770 (diff)
downloadaur-a58102350ce5dc3bd9f83aadbaadad33d157948a.tar.gz
Changes for Pro variant
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a895e1415750..5c8f3f4ca21b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Leonard Janis König <ljrk@ljrk.org>
-pkgname='otf-apple-sf-mono'
-pkgver=16.0d2e1
+pkgname='otf-apple-sf-pro'
+pkgver=16.0d18e1
pkgrel=1
-pkgdesc='Apples monospaced vairant of the San Francisco typeface family.'
+pkgdesc='Apples San Francisco typeface family. System font.'
arch=('any')
url='https://developer.apple.com/fonts/'
license=('custom:apple-restricted-font')
-source=('https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg'
+source=('https://devimages-cdn.apple.com/design/resources/download/SF-Font-Pro.dmg'
'license.awk'
'version.awk')
-sha256sums=('fc0beba1460fbe0f1f6d7c0f1eff6e09dd9cd996a24595f47dcb332614ecd541'
+sha256sums=('c0b158d8d777ef65cee37a86822d5adcefa730e1c5da115e41c5f1b4e3a83986'
'cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889'
'55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198')
makedepends=('texlive-bin' 'p7zip')
@@ -18,17 +18,17 @@ makedepends=('texlive-bin' 'p7zip')
prepare() {
cd ${srcdir}
# These are dmg images, xar and cpio archives. Just use 7z.
- 7z x -y 'SF-Mono.dmg'
- 7z x -y 'SFMonoFonts/SF Mono Fonts.pkg'
+ 7z x -y 'SF-Font-Pro.dmg'
+ 7z x -y 'SanFranciscoPro/San Francisco Pro.pkg'
7z x -y 'Payload~'
- otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/SF-Pro-Display-BoldItalic.otf | \
awk -f license.awk > LICENSE
}
pkgver() {
cd ${srcdir}
- otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/SF-Pro-Display-BoldItalic.otf | \
awk -f version.awk
}