summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Mounier2019-02-14 11:46:38 +0100
committerFlorian Mounier2019-02-14 11:46:38 +0100
commit0294237584f6705a2b0b7cb3da70334ca6200309 (patch)
treee3c263d0e9982e566d5f7483151a26a051754d5a /PKGBUILD
downloadaur-0294237584f6705a2b0b7cb3da70334ca6200309.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..798e38cde4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mounier Florian <paradoxxx.zero@gmail.com>
+# Forked from otf-fira-code-git from James Zhu <james.zhu.engineer@gmail.com>
+
+pkgname=otf-fira-code-onum-patch
+pkgver=1.206.r13.gbfe9f38
+pkgrel=1
+pkgdesc="Fira Code: monospaced font with programming ligatures fork to have ligatures with old-style num activated as well."
+arch=('any')
+url='https://github.com/paradoxxxzero/FiraCode.git'
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+provides=('otf-fira-code=1.206')
+conflicts=('otf-fira-code')
+makedepends=('git')
+install=otf.install
+source=('git+https://github.com/paradoxxxzero/FiraCode.git' 'otf.install')
+md5sums=('SKIP'
+ '9b9dbd9712ac6fefe896f704609b659c')
+
+_gitname=FiraCode
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ local weights=('Regular' 'Bold' 'Light' 'Medium' 'Retina')
+ local font='FiraCode'
+
+ for weight in ${weights[*]}; do
+ local name="${font}-${weight}.otf"
+ install -Dm644 "distr/otf/$name" "$pkgdir/usr/share/fonts/OTF/$name"
+ done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}