summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-02-21 20:49:08 +0000
committerJonathon Fernyhough2018-02-21 20:49:08 +0000
commit4f3cbfe6774a3aa3fd11da660e4793dbbbbb6310 (patch)
treed8de972df8e024101c128341dd33cfc1e8d48dfa /PKGBUILD
parentf2188208956ac3433e6fdd8e71aa63873b86590b (diff)
downloadaur-4f3cbfe6774a3aa3fd11da660e4793dbbbbb6310.tar.gz
Update for version 1.0.0 and new repo structure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffc7048a4361..33c43a79bb00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
-# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot_org>
pkgname=otf-ibm-plex-git
_pkgname=otf-ibm-plex
pkgver=latest
-pkgrel=1
+pkgrel=2
pkgdesc='IBM Plex Mono, Sans, and Serif typefaces (OTF version)'
arch=('any')
-url='https://github.com/IBM/type'
+url='https://github.com/IBM/plex'
license=('sil')
makedepends=('git')
-provides=("$_pkgname")
+provides=("$_pkgname"
+ 'otf-ibm-plex-mono'
+ 'otf-ibm-plex-sans'
+ 'otf-ibm-plex-sans-condensed'
+ 'otf-ibm-plex-serif')
conflicts=("$_pkgname")
-source=("${_pkgname}::git+https://github.com/IBM/type.git")
+source=("${_pkgname}::git+https://github.com/IBM/plex.git")
sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
# https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
( set -o pipefail
- git describe --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/v//g;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
@@ -27,11 +31,11 @@ pkgver() {
package() {
cd "$_pkgname"
- for variant in Mono Sans Serif; do
+ for variant in Mono Sans Sans-Condensed Serif; do
install -d "$pkgdir"/usr/share/fonts/OTF/ibm-plex/${variant,,}
- install -Dm644 fonts/${variant}/desktop/mac/*.otf "$pkgdir"/usr/share/fonts/OTF/ibm-plex/${variant,,}
+ install -Dm644 IBM-Plex-${variant}/fonts/complete/otf/*.otf "$pkgdir"/usr/share/fonts/OTF/ibm-plex/${variant,,}
done
# License
- install -Dm644 fonts/Mono/desktop/mac/license.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt
+ install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/license.md
}