summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin Christensen2015-06-08 11:15:38 -0600
committerDevin Christensen2015-06-08 11:15:38 -0600
commit1979739a384347c2dd4b3bd8984c86692b61922c (patch)
tree1cae50d303cf941ef07847dfeb88908e831998b3 /PKGBUILD
downloadaur-1979739a384347c2dd4b3bd8984c86692b61922c.tar.gz
Create package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1ca6fcbf42a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=otf-meslo-powerline-git
+pkgver=r71.39c99c0
+pkgrel=1
+pkgdesc="Meslo for Powerline"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('custom:Apache License, Version 2.0')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(powerline-fonts powerline-fonts-git)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts/Meslo
+ find . -iname '*.otf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}