summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBasil Skrnk2023-01-03 16:39:18 +0200
committerBasil Skrnk2023-01-03 16:39:18 +0200
commitb4730020467cb1dc6434a3494b46ff966423587f (patch)
tree562c96d8f6876fb59c20d33f6dadfc6c2854f4f4 /PKGBUILD
parentd40ac96485948402bbda394dec8edca682b6fc6c (diff)
downloadaur-b4730020467cb1dc6434a3494b46ff966423587f.tar.gz
Remove mistakes in packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3382a3dbff58..2105c3e7e09c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
# Maintainer: Harry Beadle <harrybeadle@protonmail.com>
# Maintainer: Walter Weiss <wltrwss@pm.me>
+# Other packages of Apple Fonts you could be interested in:
+# 1) otf-san-francisco
+# 2) otf-san-francisco-mono
+# are also in AUR.
+
pkgname=otf-new-york
pkgver=1
pkgrel=8
-_source_name="NY-Font-$pkgver-$pkgrel.dmg"
-pkgdesc='Apple-designed serif typeface based on essential aspects of historical type styles.'
-# Other packages of Apple Fonts you could be interested in: 1) otf-san-francisco; 2) otf-san-francisco-mono in AUR.
+_source_name='NY-Font-$pkgver-$pkgrel.dmg'
+pkgdesc='Apple-designed serif typeface based on essential aspects of historical type styles. Sourced directly from Apple.'
arch=('any')
url='https://developer.apple.com/fonts/'
license=('custom')
makedepends=('p7zip')
-source=("::https://developer.apple.com/design/downloads/NY-Font.dmg")
-source=('$_source_name::https://devimages-cdn.apple.com/design/resources/download/NY.dmg')
+source=('$_source_name::https://developer.apple.com/design/downloads/NY-Font.dmg')
sha512sums=('f0a07d5531a2bfb00c3dd9ed9c2f56e9bd5ae55efce153d34cd18005473e14aca9baa19ce044dd99201b72ab94fd576dcb1ce771b6d3d3efe37740d38ae3fad3')
prepare() {
7z x $_source_name
- 7z x "NYFonts/NY Fonts.pkg"
- 7z x "Payload~"
+ 7z x 'NYFonts/NY Fonts.pkg'
+ 7z x 'Payload~'
}
package() {
cd 'Library/Fonts/'
- install -d "${pkgdir}"/usr/share/fonts/apple
- install -m644 *.otf "${pkgdir}"/usr/share/fonts/apple/
+ install -d '${pkgdir}'/usr/share/fonts/apple
+ install -m644 *.otf '${pkgdir}'/usr/share/fonts/apple/
}