summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2019-11-06 12:48:12 +0100
committermrxx2019-11-06 12:48:12 +0100
commit6d0e3a5abd452330ee650c95bc62d7d8ecf75c0d (patch)
treead9506b921b78d62e3b546d27a96feba4b99871b /PKGBUILD
downloadaur-6d0e3a5abd452330ee650c95bc62d7d8ecf75c0d.tar.gz
Initial commit v1.022
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20e9c0ea14f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+
+pkgname=otf-recursive
+pkgver=1.022
+pkgrel=1
+_betaver=020
+_fontdir=Recursive
+pkgdesc="A variable type family built for better code & UI"
+arch=('any')
+url="https://github.com/arrowtype/recursive"
+license=('custom:SIL Open Font License 1.1')
+depends=('fontconfig' 'xorg-font-utils')
+source=("$pkgname-$pkgver.zip::${url}/releases/download/v${pkgver}/recursive-static_fonts-b${_betaver}.zip"
+"LICENSE::https://raw.githubusercontent.com/arrowtype/recursive/master/OFL.txt")
+sha1sums=('c2b2956a4fcd556bad255fe2af3913dcc2ba7253'
+ 'f200de5d9656482b8d193adda52514b6402a3cfa')
+
+package() {
+ install -D -m644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d ${pkgdir}/usr/share/fonts/OTF/${_fontdir}
+ cd ${srcdir}/recursive-static-b1_${_betaver}
+ install -Dm644 recursive_mono-static_otf/*.otf ${pkgdir}/usr/share/fonts/OTF/${_fontdir}
+ install -Dm644 recursive_sans-static_otf/*.otf ${pkgdir}/usr/share/fonts/OTF/${_fontdir}
+}