summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-08-16 13:46:42 +1200
committercaltlgin2020-08-16 13:46:42 +1200
commit5c49ee14d445b9a47cc8f17135de60c31e40caa8 (patch)
tree64ede25e3825288608786dd2d4575599fca1f474 /PKGBUILD
parent883deac521f49f66e03da7d353c04a8cb5d9bbd0 (diff)
downloadaur-5c49ee14d445b9a47cc8f17135de60c31e40caa8.tar.gz
Adopt and Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69227394f166..177f13537214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: xpt <user.xpt@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: xpt <user.xpt@gmail.com>
-pkgname=otf-ryman-eco
+_pkgname=ryman-eco
+pkgname="otf-${_pkgname}"
pkgver=1.0
-pkgrel=0
-pkgdesc="The world's most beautiful sustainable font"
+pkgrel=2
+pkgdesc='Environmentally sustainable typeface'
arch=('any')
-url="http://rymaneco.co.uk"
-license=('custom:OFL')
-depends=('fontconfig' 'xorg-font-utils')
-install=otf.install
-source=('http://rymaneco.co.uk/download/ryman-eco.zip')
-md5sums=('faca025548b89add18d3891593f800e5')
+url='https://rymaneco.co.uk'
+license=('custom')
+source=("${_pkgname}-${pkgver}.zip::${url}/download/${_pkgname}.zip")
+sha256sums=('be47185a8ae794ce56a837aae7d7687d46b0c6fd009fde8d299829e7950caa86')
package() {
- cd "$srcdir/Ryman Eco"
- install -d "$pkgdir/usr/share/fonts/OTF"
- install -m644 'Ryman Eco'/*.otf "$pkgdir/usr/share/fonts/OTF/"
- install -Dm644 "Ryman Eco End User License Agreement.pdf" "$pkgdir/usr/share/licenses/$pkgname/License.pdf"
+ cd "Ryman Eco"
+ install -Dm644 -t "${pkgdir}/usr/share/fonts/OTF" "Ryman Eco/RymanEco-Regular.otf"
+ install -Dm644 'Ryman EcoPoster.pdf' "${pkgdir}/usr/share/doc/${_pkgname}/poster.pdf"
+ install -Dm644 'Ryman Eco End User License Agreement.pdf' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.pdf"
}
+
+# vim:set ts=2 sw=2 et: