summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGavin Lloyd2017-03-06 16:15:58 -0800
committerGavin Lloyd2017-03-06 16:15:58 -0800
commit7daf250a738bf8cbd230c1718f2c13a3415202ab (patch)
treeba51a42d2c57c239d2a650708606298c5079d672 /PKGBUILD
downloadaur-7daf250a738bf8cbd230c1718f2c13a3415202ab.tar.gz
Init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e919c4c024
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=otf-san-francisco
+pkgver=1.0
+pkgrel=1
+pkgdesc='The system font for macOS, iOS, watchOS, and tvOS'
+arch=('any')
+license=('custom')
+url='https://developer.apple.com/fonts/'
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('xar')
+source=("https://developer.apple.com/fonts/downloads/SFUI.zip")
+sha256sums=('61d21ddba98b73f96f4c256aba92e490448f80c346e934245627cedbf8d3291f')
+
+package() {
+ cd "$srcdir/SFUI"
+
+ mkdir pkg
+ xar -xf 'San Francisco UI.pkg' -C pkg
+ gunzip -dc "pkg/San Francisco UI.pkg/Payload" | cpio -i
+
+ install -d $pkgdir/usr/share/fonts/OTF/
+ install -m644 Library/Fonts/*.otf $pkgdir/usr/share/fonts/OTF/
+
+ install -d $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 'SF UI Font License.rtf' $pkgdir/usr/share/licenses/$pkgname/LICENSE.rtf
+}