summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin Christensen2015-06-08 11:16:41 -0600
committerDevin Christensen2015-06-08 11:16:41 -0600
commit456300636dabf6bc9995dfe3cb08b4c14554792a (patch)
tree80f217057435be892c9f6838f9c1c83d09348253 /PKGBUILD
downloadaur-456300636dabf6bc9995dfe3cb08b4c14554792a.tar.gz
Create package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d06c0789462a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=otf-sauce-code-powerline-git
+pkgver=r71.39c99c0
+pkgrel=1
+pkgdesc="Sauce Code Powerline"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('custom:SIL Open Font License, Version 1.1')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(powerline-fonts powerline-fonts-git)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts/SourceCodePro
+ find . -iname '*.otf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}