summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPau Ruiz i Safont2018-04-24 10:42:37 +0100
committerPau Ruiz i Safont2018-04-24 10:42:37 +0100
commitbb4092939476a7553aed762ad90fa5c8d76753f0 (patch)
tree72cdbcb7ac67ae00cbe6da09495d245ac6badf67 /PKGBUILD
parent1510816b4de4f695409bce3c21df225651524444 (diff)
downloadaur-bb4092939476a7553aed762ad90fa5c8d76753f0.tar.gz
maintenance: adapt package for alpha package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 611c24a4fca8..d1a619f5e1d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Pau Ruiz Safont <unduthegun@gmail.com>
pkgname=otfcc
pkgver=0.9.6
-pkgrel=1
+pkgrel=2
+tgzver=0.9.6
+foldname="${pkgname}-${tgzver}"
pkgdesc='A C library and utility for parsing and writing OpenType font files.'
arch=('i686' 'x86_64')
url='https://github.com/caryll/otfcc'
license=('APACHE')
makedepends=('premake-git') # premake5
-source=("https://github.com/caryll/${pkgname}/archive/v${pkgver}.tar.gz")
+source=("https://github.com/caryll/${pkgname}/archive/v${tgzver}.tar.gz")
md5sums=('4a1f654612a72f936337f5ec82dcaa46')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${foldname}"
premake5 gmake
cd build/gmake
if [ "${CARCH}" = "x86_64" ]; then
@@ -24,5 +26,5 @@ build() {
package() {
install -d "${pkgdir}/usr/bin"
- install ${pkgname}-${pkgver}/bin/release-x*/otfcc* "${pkgdir}/usr/bin/"
+ install ${foldname}/bin/release-x*/otfcc* "${pkgdir}/usr/bin/"
}